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How to Create Accessible

PDF Documents

Purpose

Ensuring accessibility in PDF documents is essential for users who rely on assistive technologies.
PDF documents are widely used due to their compatibility across various platforms. Begin with an
accessible source document such as a Word document before converting it to a PDF.

Tips for Making PDF Documents Accessible

Use the accessibility checker
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Adobe Acrobat Pro’s built-in tool will identify possible issues in your document and give
suggestions on how to correct them (remediating the source document is best).
*Disclaimer: Although good practice, it should not be assumed that the tool guarantees

100% accessibility compliance with WCAG 2.1, level AA.

To use the accessibility checker tool:
1. Select “All Tools” -> “View More” -> “Prepare for accessibility”
2. Select “Check for Accessibility” -> “Start Checking”
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I Accessibility Checker Opticns X
€ Prepare for accessibility X

Report Options

[a Automatically tag PDF B Create accessibility report

Folder: C:\Usersimak herb\AppDatalR ing\Adobe\Acrobat\DCiAccReports Choose...

() attach report to document

i)
L)

Change reading options Page Range
[« XA pages in document (@) Pages from 1 to |1

Checking Options (31 of 32 in all categories)

®

Check for accessibility

&

Open accessibility report

Category:  Document e
[ Identify form fields

B Accessibility permission flag is set
£ Add alternate text 8 Document is not image-only PDF

8 Document is tagged PDOF

8 Use setup assistant
* 8 Document structure provides a logical reading order

E¢ Fix reading order @ Text language is specified

@ Document title is showing in title bar
B Bockmarks are present in large documents
8 Document has appropriate color contrast

Select All Clear All

8 show this dialog when the Checker starts

== — Conce

3. Once the check is complete, a side panel will show a list of any issues found for you

to fix.
4. Use the drop-down arrows next to each section to see a detailed list of “passed” and

“failed” elements.

¥ Accessibility Checker

— Document (3 issues)

Accessibility permission flag - Passed
Image-only PDF - Passed

Tagged PDF - Passed

Logical Reading Order - Needs manual check

Primary language - Passed

oo NEBo 2 e

— @ Title - Failed
Bookmarks - Passed

'!1-' Color contrast - Meeds manual check

by Page Content

» Forms

» Alternate Text
3 Tables
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Remediate issues in the example above:
e In this example, the report came back with 3 document issues - logical reading order, title,
and color contrast.
¢ Logical Reading Order:
1. The blue question mark icon indicates “Needs Manual Check.”
2. Follow instructions under “Check the reading order” section in this document to
review.
3. Once remediated, right-click on the question mark icon in the side panel and select
“Pass.”

1. Thered “X” icon indicates “Failed.”
2. Right-click on the “X” icon in the side panel and select “Fix”
3. Enter the title of the document -> click “OK.”

e Color Contrast:
1. The blue question mark icon indicates “Needs Manual Check.”
2. Review your document for any text and background colors that have low contrast.
3. Once you have reviewed the colors, right-click on the question mark icon in the side
panel and select “Pass.”

Check for tags

e Tags enable assistive technologies to read and interact with PDF documents by telling the
user what is on the page.

e Headings (H1), paragraphs (P), images, tables, form fields, and lists are tag types.
e Check the tags panel to ensure there are tags, and if not, add them.

e Add a tag:
1. Select “All Tools” -> “View More” -> “Prepare for Accessibility”
2. Select “Automatically tag PDF”
3. Use the Accessibility tags panel to review and edit tags.
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e View tags panel:
1. Select menu -> “View” -> “Show/Hide” -> “Side Panels” -> “Accessibility Tags.”

- Q 1:{ O Howtocreateacce. % + Create ® O A
Open Cirl+0 o Find text ortools Q) B <
Open recent files > TUUOWITIE LNE LEES LU LR 811U Ul BdCH Page.

Create > + Thedefault reading order is top to bottom, left to right. If a document is designed with
Combine files multiple columns of text, all elements should be tagged in the correct reading order to avoid
— the assistive technology mistakenly reading the text across the page from left to right.
Save Cirl+S
Save as Shift+CirieS * Example of setting the correct reading order:
Save as other >
Export a PDF > Heading Heading
@ Lorem ipsum dolor sit amet, consectetuer Lorem ipsum dolor sit amet, consectetuer
Protect Using Password adipiscing elit. Mazcenas porttitor congus adipiscing elit. Maecenas porttitor congue

Request e-signatures massa. Fusce posuers, magna sed pulvinar massa. Fusce posuere, magna sed pulvinar
4 g ultricies, purus lectus malesuada libero, sit ultricies, purus lectus malesuada libero, sit
Share file . amet commaodo magna eros quis uma. amet commodo magna e10s quis urna.
Y
Print Ctrl+p Nunc viverr - - Nunc viverra | et enim. Fusce est.
Search > ) Vivemus a v (@ Accessibility Checker vamus & tellus.
Pellentesq llentesque habitant morbi tristique
SEnECtus e nectus et netus et malesuads fames sc
turpis egests A urpis egestas. Proin pharetra nonummy pede.
Mauris et or| suris et orci.
| C? Attachments
paste Ctrisy Aenean nec _ Renesn nec lorem. In porttitor. Donec lsorest
Undo, Redo & mare > nonummya{ ¥ [ Bookmarks honummy sugue|
L Rotate view > vulputate vit B conent Vulputate vitae, pretium mattis, nunc. Mauris
Disable new Acrobat eget neque - Bget neque st sem venenatis eleifend. Ut
Page navigation > nonummy. © Destinations nonummy.
Page display > Heading 3 Layers Suspendisse dui purus, scelerisque at,
Window > @ Vulputate vitae, pretium mattis, nunc. Mauris
o Z >
coom B ModelTiee eget neque st sem venenats eleifend. Ut
Help * . % Order nonummy.
Preferences. | v @ pages
Protect)
forecten Customize toolbar &% signatures
Exit application Ctri+Q Display size >

Rulers & grids H

Read out loud H
Cursor coordinates

Tracker..

Check alt text

2. The tags panel shows tagged elements sequence. Review order and rearrange as
needed.
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Check the reading order
e Review the order of the tags in the tags panel to ensure the correct reading order.
e Screen readers use the tag order to read content, starting at the top of the tag tree and
following the tags to the end of each page.
e The default reading order is top to bottom, left to right. If a document is designed with
multiple columns of text, all elements should be tagged in the correct reading order to avoid
the assistive technology mistakenly reading the text across the page from left to right.
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e Example of setting the correct reading order:

Heading

Lorem ipsum dolor sit amet, consectatuar
adipiscing elit. Mascenas porttitor congus
massa. Fusce posuere, magna sed pulvingr
ultricies, purus lectus malesuada libero, sit
amet commodo magna ercs guis urna.

®

Munc viverra imperdiet enim. Fusce est,
Vivamus & tellus.

Pellentesque habitant morbi tristigus
senectus et netus et malesuada fames ac
turpis egestas. Proin pharetra nonummy pede.
Mauris et orei.

Aenean nec lorem. In porttitor. Donec lacrest
RoRUMMY sUgue.

Suspendisse dui purus, scelerisque at,
vulputate vitse, pretium mattis, nunc. Mauris
adat neque st sem venenatis eleifend. Ut
ML Y.

Heading

Chart Title

Calegoryl Caegory2? Coegory3 Cakegoryd

@ 2
Sedes 3

mEefes]l mEefes 2

e Reading order tool:

Heading

Lorem ipsum dolor sit amet, consectetusr
adipiscing elit. Mascenas porttitor congue
massa. Fusce posuere, megna sed pulvinar
ultricies, purus lectus maleswads libero, sit
amet commaodo magna ercs guis urma.

Munc viverra imperdiet enim. Fusce est.
Vivamus a tellus.

Pellentesgue habitant morki tristigue
senectus et netus et malesuada fames ac
turpis egestas. Proin pharetra nonummy peds.
Mauris et orci.

Aenean nec lorem. In porttitor. Donec laorest
ORI SUgUE]

Suspendisse dui purus, scelerisque at,
vulputste vitae, pretium mattis, nunc. Mauris
egat neque at sem venengtis eleifend. Ut
NOnUMTY.

Suspendisse dui purus, scelerisgue at,
vulputste vitae, pretium mattis, nunc. Mauris
egat neque at sem venenatis eleifend. Ut
Mo M.

1. Use the reading order tool to fix the reading order and tagging problems.

2. Select “All Tools” -> “Prepare for Accessibility” -> “Fix Reading Order”

3. Inthe reading order form, you can drag a rectangle around the content you want to
retag and click the corresponding label.

4. Select “Show Order Panel” to view the reading order -> drag the tag to the correct

location.
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Alltools  Edit  Convert  E-Sign Reading Order

< Prepare for accessibility % Draw a rectangle around the content then click one of
the buttons below:

[& Automatically tag PDF Ll vt Figure
Form Field Figure/Caption

Heading 1 Heading 4 Table
Change reading options

Heading 2 Heading 5 Cell

Check for accessibili
@ ty Heading 3 Heading & Formula
Gi\g Open accessibility report Reference (g) Note (z) Background/Artifact
[ Identify form fields
Table Editor
EY Add alternate text
B show page content groups | |

% Use setup assistant
© Page content order

i

Et Fix reading order () structure types

B show table cells | |

B Display like elements ina single block

B show tables and figures | |
Clear Page Structure_. Show Order Panel l _
Help Close
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H [8] Insert screenshot
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mmm) [Pyrpose

‘ suring accessibility in PDF documents is essential for users who rely on assistive technologies.
PDF documents are widely used due to their compatibility across various platforms. Begin with an
accessible source document such as a Word document before converting it to PDE.

—) [3lips for Making PDF Documents Accessible

‘se the accessibility checker

Adobe Acrobat Pro’s built-in tool will tell you about possible issues in your document and
give suggestions on how to correct them.

® Select “All Tools” -> “View More” -> “Prepare for accessibility”

» Select “Check for Accessibility” -> “Start Checking”

® Once the check is complete, a panelwill list any issues found.

® Select the ellipsis in the Accessibility Checker panel and Acrobat will either fix the items
automatically or prompt you to fix them manually.

Use color carefully
e High contrast color schemes and texture variations make it easier for people with low vision
and colorblindness to see and use the content.

e Use high contrast color schemes for background and text. You can test your color schemes
by printing them in black & white.

Fill in document properties
1. Goto “Menu” -> “Document Properties”
2. Enter information for the title, subject, and author, click “OK.”
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Document Properties X
Description  Security Fonts  Initial View Custom Advanced
Description

File: How to create accessible PDFs (copy).pdf

Title: |

Author: |

Subject: |

Keywaords:

Created:  6/4/2025 1:04:16 PM Additional Metadata.
‘ Modified:  6/4/2025 1:06:26 PM

Application:  Acrobat PDFMaker 25 for Word

Advanced
PDF Producer:  Adobe Acrobat (64-bit) 25 Paper Capture Plug-in
PDF Version: 16 (Acrobat 7x)
Location: Adobe cloud storage
File Size: 15520 KB {158,928 Bytes)
Page Size: 850x11.00in Number of Pages: 4

Tegged PDF: Mo Fast Web View: Yes

Use bookmarks
e Bookmarks improve navigation for individuals using screen readers.
e Include bookmarks for all main sections of the document.

e Use the bookmark tab on the menu to the right of the document. If it does not show up, add
bookmark view.
1. Menu -> “View” -> “Show/Hide” -> “Side Panels” -> “Bookmarks.”

x Bookmarks B - @
E_

hd Purpose

Tips for Making PDF Documenits
Accessible

Use the accessibility checker
Fill in document properties

Use bookmarks

o o N &

Use headings as an outline

hd How to Create Accessible PDF
Documents

Purpose or Overview

> Tips for Making PDF Documents
Accessible
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- @ T O Howtocreateacce. X | + Create

Open. ctl+0
Open recent files b
Create >
Combine files
Save Ctrl+s
Saveas. Shift=Cir=s Check the reading order
Save as other > . p
+» Review the order of the tags in the tags panel to ensure the correct reac
Exporta PDF b

*» Screen readers use the tag order to read content, starting at the top of*

Protect Using Password following the tags to the end of each page.

Request e-signatures s The default reading order is top to bottom, left to right. If a document is
q et 8 p 8
Share file multiple columns of text, all elements should be tagged in the correcti
Srint Cirisp the assistive technology mistaken|v reading the text across the page frc
. v (@@ Accessibility Checker
Search ’ ¢ Example of setting the corn @ v
v (B Accessibilitytags
Ul  Articles
Heading
Paste Ctrlew @ Lorem ipsum dolor sit amet, consectetuer & Attachments Eecte
- adipiscing elit. Maecenas porttitor congue = DE Er T T ot
Undo, Redo & more > massa. Fusce posuere, magna sed pulvinar = = PL
: Fus lectus mal da libero, sit v (@ Comment B live
/i 5
Disable new Acrobat a imperdiet enim. Fusce est. pce &
Page navigation » E""ze @ Destinations
Page display > be habitent morbi tristique 23 Leyers ique
Window > I netus et malesuada fames ac fame
Zoom >
B tss. Proin pharetra nonummy ped v E Model Tree num
Help > Read mode Ctil+H  eei. v z Order
Preferences.. Ctri+k Full screen mode Cirl+L  Elorem. In porttitor. Donec laoreg. v [ Pages lonec
Protecti >
forection Customize toolbar & signatures ue 8
Document properties.. Ctrl+D Display theme b m Reset Panes unc.
Exit application ctrl+Q Display size b = e
Rulers & grids > nonumimy.
Read out loud b .
- Cursor coordinates Suspendisse dui purus, scelerisque &
Tracker. vulputste vitae, pretium mattis, nunc.
T Thart Tile eget neque at sem venenatis eleffend
nanumm

Use headings as an outline
e Headings are one of the most useful tools to help the reader find information easily.
e There should only be one heading level 1 or your document will not pass compliance.

e Heading structure is hierarchal (there should not be headings level 3 without headings level
2).

Heading Level 1 » How to Create Accessible PDF Documents

Heading Level 2 » Purpose or Overview
Description of the purpose of accessibility in PDF documents.

» Tips for Making PDF Documents Accessible

Heading Level 3 P Tip #1
1. Overview
2. “How to” Instructions

Heading Level 4 >

P Tip #2
3. Overview

4. “How to” Instructions

% Tip #3
> 5. Overview
6. “How to” Instructions
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Check alt text
e Add clear, concise descriptions to all images, charts, tables, shapes, embedded objects and
SmartArt graphics.
o Assistive Technology will read “image” or “graphic” without alt-text.
e For alogo, simply use the description “Company Name lcon” or “Company Name Logo.”
e For a pie chart or graph, provide all data points and values for each section.

e To verify alt text is added to an object:
1. Select “All Tools” -> “View More” -> “Prepare for Accessibility”
2. Select “Add Alternate Text” -> “OK”
3. Use “Set Alternate Text” form to fill out alt text for all figures.

€ Prepare for accessibility x n

[a Automatically tag PDF @‘
‘él -
Check the reading order
Change reading options “ * Review the order of the tags int
@ Check for accessibility i.'?.'L e Screen readers use the tag orde
following the tags to the end of
@ Open accessibility report &, * The default reading order is top
multiple columns of text, all ele
[ Identify form fields the assistive technology mistak
. " ot
EY Add alternate text Py %
1§ Use setup assistant 'o Acrobat will detect all figures in this document and display associated alternate text.
4 uE
=% Fix reading order =1

() Do not show this message again ulvit

T VAU & Tl

Set Alternate Text *

Image 1of 10 3

Alternate text: [_] Decorative figure

Save & Close Cancel

Convert scanned text
e Documents should not contain scanned text. If it does, recreate the PDF file using the source
document or convert it to include true text.

e Convert on Adobe Acrobat:
1. Adobe Acrobat offers an Optical Character Recognition (OCR) software. Use the OCR
tool to automatically convert the document to a PDF with editable text.
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2. Select “All Tools” -> “Scan & OCR” -> “In this File” -> set the language -> “Recognize

Text.”
All tools x
€ Scan &OCR x
[2  Exporta PDF n
MODIFY PAGE
52 EditaPDF S)
cC w & G
Create 3 PDF “ 2,
ENHANCE FILE (<]
E';B Compbine files B
1™ Enhance scanned file p iA'L
Organize pages
(8] Enhance camera image | a,

Send for comments
RECOGNIZE TEXT

@ Request esignatures
B inthisfile

Scan & OCR |
[ In multiple f 03
m P Pages
[I' vy Turn scans or images into ( ]
& searchable, editable PDFs @ Correctreca | All pages v |
5 Redacta PDF Language _
Bates numb | English(US) v |
Compress a PDF
[& Prepareaform Bates numb

£ Fill&sign

Set the document language
e Setting the document language in a PDF enables some screen readers to switch to the
appropriate language.
e This is the first step in checking for accessibility of the document to ensure information is
relayed in the user’s expected language.

Artifacts
o Artifacts are elements that are ignored by a screen reader, such as decorative borders or
background elements that do not contain useful information.
e Acrobat may incorrectly tag artifacts as figure tags which need to be removed.
e Toremove the artifact tag, redefine them with a “Background/Artifact” tag or delete the tag.
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